Deltacam.com

Deltacam forum
It is currently Thu Apr 27, 2017 9:02 am

All times are UTC




Post new topic Reply to topic  [ 14 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: 03 Forester X auto
PostPosted: Fri Jan 14, 2011 12:40 am 
Offline
Site Admin

Joined: Wed Nov 24, 2010 10:14 pm
Posts: 120
Do you have them installed yet?


Top
 Profile  
 
 Post subject: Re: 03 Forester X auto
PostPosted: Sat Jan 15, 2011 5:14 am 
Offline

Joined: Mon Dec 20, 2010 10:07 pm
Posts: 10
Not yet, I am working on getting the right gaskets and then setting up the headwork. I am aiming for the first weekend in February or the last of January. I have two weekend birthdays coming up the 16th and 22nd for immediate family or I would be all over this. I will post when I get them installed and let you know how everything went, I almost can't wait to get them in but priorities and getting it all done right the first time are holding me back.

You will hear back as soon as I get it all torn down and buttoned back up. Thanks,

Ruben


Top
 Profile  
 
 Post subject: Re: 03 Forester X auto
PostPosted: Sun Jan 30, 2011 12:50 am 
Offline

Joined: Mon Dec 20, 2010 10:07 pm
Posts: 10
It is finally done, we tore into it last weekend took the engine down to the block and sent the heads for machining. We started building thursday evening and got everything done today and the engine put back in. So so good, got the cam break-in taken care of and ran it just a little since it was already dark. I will give a proper test drive tomorrow and let you know how it feels, but so far the engine seems to rev smoother and quite a bit quicker I can't wait to give it a test run. I will need to adjust the valve's they are a little noisy, but that will be at the end of next week so everything has time to settle, and then I will change the oil and adjust the valves. Most importantly no CEL, so thank you guys for your great work and for answering all my questions. I am already impressed with the cams and I haven't even driven it.


Top
 Profile  
 
 Post subject: Re: 03 Forester X auto
PostPosted: Sat Feb 05, 2011 12:31 am 
Offline

Joined: Mon Dec 20, 2010 10:07 pm
Posts: 10
Got everything buttoned down, got the valves almost all adjusted properly and it is running like a champ. Had a little scare with the cel turned out to be an unplugged sensor so everything is good so far and it has good pickup from 1800-redline the ecm is still working out part throttle shift points so around town it seems to shift a little too soon. Overall the engine feels strong and we used the factory valvelash specs and so far no cel, after plugging all the sensors in that is. I will give it a week of driving and report back again. So far I am still very happy with this project.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group